Quantcast

Release notice for 1.6??? Can we drop support for python 2.6??

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Release notice for 1.6??? Can we drop support for python 2.6??

John P. Rouillard
Hi all:

The current development head has 25 features and 44 bug fixes in
it. The automated tests code coverage has increased from 52% to
63%. Thanks to jerrykan for setting up the CI environment for this.

I really would like to get this released.

 1) It has been almost a year since 1.5.1.
 2) I have a system adminsration tracker that I would like to release
    but it only works on 1.6.0 or newer.

I am planning on sending an email to the roundup-users list
highlighting the changes and asking for testers. However before I do
that I want to find out if we are going to support python 2.6.

I only have a 2.7 system available and the CI evironment only tests
2.7. Is it fair to say that we only test with 2.7 but 2.6 may
work?

Python 2.5 is not expected to work work becaused we are now using
standard library functions present in 2.6/2.7.

Comments? Also who volunteers to be the release engineer?

--
                                -- rouilj
John Rouillard
===========================================================================
My employers don't acknowledge my existence much less my opinions.

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Roundup-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/roundup-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Release notice for 1.6??? Can we drop support for python 2.6??

Thomas Arendsen Hein
* John P. Rouillard <[hidden email]> [20170219 21:16]:
> I only have a 2.7 system available and the CI evironment only tests
> 2.7. Is it fair to say that we only test with 2.7 but 2.6 may
> work?

In this case I'd recommend requiring 2.7.

This will drop support for Debian squeeze, but even LTS support for
that ended almost one year ago.

Regards,
Thomas

--
[hidden email] - http://intevation.de/~thomas/ - OpenPGP key: 0x5816791A
Intevation GmbH, Neuer Graben 17, 49074 Osnabrueck - AG Osnabrueck, HR B 18998
Geschaeftsfuehrer: Frank Koormann, Bernhard Reiter, Dr. Jan-Oliver Wagner

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Roundup-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/roundup-devel
Loading...